Categories


Tags


如何禁止用ip直接访问到我的服务器?

如何禁止用ip直接访问到我的服务器?

windows下关闭或取消主机名空的站点

打开Internet 信息服务(IIS)管理器-如图1所示,关闭站点或者删除空主机名的绑定

图1:

linux下利用apache的虚拟主机机制,没有绑定的域名或者ip直接访问时会访问到第一个虚拟主机

注:以下操作都需远程登录ssh执行命令

centos-默认apache:

编辑配置文件

vi /etc/httpd/conf/httpd.conf

在NameVirtualHost *:80下任意添加一个虚拟主机配置,如

<VirtualHost *:80>

DocumentRoot "/var/www/html"

ServerName www.test.com

<Directory "/var/www/html">

deny from all

</Directory>

</VirtualHost>

重启服务即可

service httpd restart

centos-wd:

只需删除一个文件即可

rm -f /www/web/default/index.php

ubuntu:

vi /etc/apache2/ports.conf

在NameVirtualHost *:80下任意添加一个虚拟主机配置,如

<VirtualHost *:80>

DocumentRoot "/var/www/html"

ServerName www.test.com

<Directory "/var/www/html">

deny from all

</Directory>

</VirtualHost>

重启服务即可

/etc/init.d/apache2 restart

来源:西部数码


Public @ 2011-12-04 16:13:29

windows 2003 64位系统php运行报错:1% 不是有效的 win32 应用程序

问题一:php运行报错:1% 不是有效的 win32 应用程序php环境配置完毕后,运行html成功,但运行php就报错,错误提示是“1% 不是有效的 win32 应用程序”,英文报%1 is not a valid Win32 application。第一次碰到这样的问题,经过搜索和试验,问题终于解决。报错原因:由于在64位操作系统里,默认配置下,IIS工作在64位模式下,这会让许多32位的应用

Public @ 2018-05-05 15:47:15

Windows Server 2008R2系统安装Oracle10g数据库

安装Oracle10g数据库前,需要先安装Windows Server 2008R2操作系统和一些必要的软件。以下是大致的步骤: 1. 安装Windows Server 2008R2操作系统,确保系统满足Oracle10g的要求,如CPU、内存等。 2. 在Windows Server 2008R2系统上安装必要的软件,如Java Runtime Environment (JRE)、.NET

Public @ 2023-06-18 06:00:20

利用安全组设置拦截外网访问服务器某个端口

进入入口:登陆管理中心,业务管理--安全及监测--安全组点击添加按钮添加安全组。创建好以后点击【规则】添加对应的信息。image.png本文示例是禁止外网访问服务器3306端口,但单独设置准许指定ip访问。实际使用时设置自己需要的端口即可。image.png设置后,所以访问服务器3306端口的访问都会被拦截。关于目前端口设置说明:目标端口:服务器不想其他人访问的端口。如果您需要拦截其他服务端口,具

Public @ 2010-06-17 16:13:35

如何禁止用ip直接访问到我的服务器?

如何禁止用ip直接访问到我的服务器?windows下关闭或取消主机名空的站点打开Internet 信息服务(IIS)管理器-如图1所示,关闭站点或者删除空主机名的绑定图1:linux下利用apache的虚拟主机机制,没有绑定的域名或者ip直接访问时会访问到第一个虚拟主机注:以下操作都需远程登录ssh执行命令centos-默认apache:编辑配置文件vi /etc/httpd/conf/httpd

Public @ 2011-12-04 16:13:29

更多您感兴趣的搜索

0.454898s