Categories


Tags


如何禁止用ip直接访问到我的服务器?

如何禁止用ip直接访问到我的服务器?

windows下关闭或取消主机名空的站点

打开Internet 信息服务(IIS)管理器-如图1所示,关闭站点或者删除空主机名的绑定

图1:

linux下利用apache的虚拟主机机制,没有绑定的域名或者ip直接访问时会访问到第一个虚拟主机

注:以下操作都需远程登录ssh执行命令

centos-默认apache:

编辑配置文件

vi /etc/httpd/conf/httpd.conf

在NameVirtualHost *:80下任意添加一个虚拟主机配置,如

<VirtualHost *:80>

DocumentRoot "/var/www/html"

ServerName www.test.com

<Directory "/var/www/html">

deny from all

</Directory>

</VirtualHost>

重启服务即可

service httpd restart

centos-wd:

只需删除一个文件即可

rm -f /www/web/default/index.php

ubuntu:

vi /etc/apache2/ports.conf

在NameVirtualHost *:80下任意添加一个虚拟主机配置,如

<VirtualHost *:80>

DocumentRoot "/var/www/html"

ServerName www.test.com

<Directory "/var/www/html">

deny from all

</Directory>

</VirtualHost>

重启服务即可

/etc/init.d/apache2 restart

来源:西部数码


Public @ 2011-12-04 16:13:29

保护IIS服务器的15个技巧

1. 安装最新的安全补丁。确保您的操作系统和IIS服务器都已安装最新的安全补丁,以保护您的服务器免受已知漏洞的攻击。 2. 打开防火墙。通过防火墙阻止访问IIS服务器的非授权用户,以加强安全性。 3. 使用SSL/TLS加密协议。使用SSL/TLS加密协议来保护通信,防止中间人攻击。 4. 禁用不必要的协议和服务。禁用不需要的协议和服务,以减少攻击面,例如FTP和Telnet。 5. 限制

Public @ 2023-04-30 00:00:16

清理网站挂马代码(适用vps云主机服务器)

VPS/云主机若发现被挂马,请立即上服务器停止您的IIS或apache,为避免您对网站程序不熟悉导致误清理,请联系您的网站开发人员登录服务器处理。清理方法(以下操作有风险,建议备份好数据并联系网站开发人员处理!):首先下载一个文本替换专家,http://download.myhostadmin.net/%E7%B3%BB%E7%BB%9F%E5%B7%A5%E5%85%B7/%E6%96%87%E

Public @ 2012-08-06 16:13:27

网站打不开,重启一下就好,到底为什么?

当我们买了一云台服务器,在服务器上部署了一套网站,正常情况下都是可以正常访问的,但是就是有一些时候网站打不开,然后重启了下服务器又可以了。这种情况是什么原因导致的呢?当出现网站打不开而服务器又可以正常远程的情况下,这时候就要我们评估下该服务器上所部署网站的并发访问和我们的带宽以及我们的服务器自身配置是否成正比的关系了。当我们的网站在一开始时候是正常访问的,过段时间网站打开速度非常慢甚至打不开,这种

Public @ 2016-04-01 16:13:20

网站打开503报错,应用程序池频繁自动关闭的解决方案

网站打开提示503 Service Temporarily Unavailable查看服务器端应用程序池开启之后一旦访问网站一次应用程序池就会自动关闭,系统日志发现很多w3wp报错日志.TIM截图20190405213037.jpg应用程序池老是自动关闭TIM截图20190405213647.jpg原因是:之前可能用网站安全狗扫描完修复了,网站安全狗在网站ISAPI筛选器里面自动加了两行或者一行语

Public @ 2015-09-29 16:13:19

更多您感兴趣的搜索

0.629534s