Categories


Tags


如何禁止用ip直接访问到我的服务器?

如何禁止用ip直接访问到我的服务器?

windows下关闭或取消主机名空的站点

打开Internet 信息服务(IIS)管理器-如图1所示,关闭站点或者删除空主机名的绑定

图1:

linux下利用apache的虚拟主机机制,没有绑定的域名或者ip直接访问时会访问到第一个虚拟主机

注:以下操作都需远程登录ssh执行命令

centos-默认apache:

编辑配置文件

vi /etc/httpd/conf/httpd.conf

在NameVirtualHost *:80下任意添加一个虚拟主机配置,如

<VirtualHost *:80>

DocumentRoot "/var/www/html"

ServerName www.test.com

<Directory "/var/www/html">

deny from all

</Directory>

</VirtualHost>

重启服务即可

service httpd restart

centos-wd:

只需删除一个文件即可

rm -f /www/web/default/index.php

ubuntu:

vi /etc/apache2/ports.conf

在NameVirtualHost *:80下任意添加一个虚拟主机配置,如

<VirtualHost *:80>

DocumentRoot "/var/www/html"

ServerName www.test.com

<Directory "/var/www/html">

deny from all

</Directory>

</VirtualHost>

重启服务即可

/etc/init.d/apache2 restart

来源:西部数码


Public @ 2011-12-04 16:13:29

Windows IIS日志文件分析神器

Windows Server具有事件日志记录的功能,其IIS日志文件里记录了包括下列信息:谁访问了您的站点,访问者查看了哪些内容等等。通过定期检查这些日志文件,网站管理员可以检测到服务器或站点的哪些方面易受攻击或存在其他安全隐患。不过,目前的日志分析工具并不是很完善,有些功能并不具备,特别是针对特定需求的分析难以实现,这里就介绍一个日志分析神器,可以像使用SQL软件一样个性化分析日志。LogPar

Public @ 2017-01-03 15:47:26

Windows Server 2008 IIS安装教程

以下是在Windows Server 2008上安装IIS的步骤: 1. 在服务器上登陆管理员帐户。 2. 打开服务器管理器,单击左侧的角色。 3. 单击右侧的添加角色链接。 4. 在“添加角色向导”窗口中,单击“下一步”。 5. 选择“Web服务器(IIS)”角色,单击“下一步”。 6. 阅读“Web服务器(IIS)”角色的概述,单击“下一步”。 7. 在“Web服务器(IIS)”

Public @ 2023-06-02 20:50:34

利用安全组设置拦截外网访问服务器某个端口

进入入口:登陆管理中心,业务管理--安全及监测--安全组点击添加按钮添加安全组。创建好以后点击【规则】添加对应的信息。image.png本文示例是禁止外网访问服务器3306端口,但单独设置准许指定ip访问。实际使用时设置自己需要的端口即可。image.png设置后,所以访问服务器3306端口的访问都会被拦截。关于目前端口设置说明:目标端口:服务器不想其他人访问的端口。如果您需要拦截其他服务端口,具

Public @ 2010-06-17 16:13:35

网站打开503报错,应用程序池频繁自动关闭的解决方案

网站打开提示503 Service Temporarily Unavailable查看服务器端应用程序池开启之后一旦访问网站一次应用程序池就会自动关闭,系统日志发现很多w3wp报错日志.TIM截图20190405213037.jpg应用程序池老是自动关闭TIM截图20190405213647.jpg原因是:之前可能用网站安全狗扫描完修复了,网站安全狗在网站ISAPI筛选器里面自动加了两行或者一行语

Public @ 2015-09-29 16:13:19

更多您感兴趣的搜索

0.573055s