Categories


Tags


在IIS7下使用ASP连接ACCESS数据库时提示如下错误的处理方法

“/”应用程序中的服务器错误。

未在本地计算机上注册“microsoft.jet.oledb.4.0”提供程序。

这是由于我们使用的Win2008系统是64位的,以前Win2003是32位。有以下两种解决方法:

1、修改连接数据库的代码:

如原代码是

DataPath = "App_Data/#data.mdb";

String constring = "provider=microsoft.jet.oledb.4.0;data source=" + HttpContext.Current.Server.MapPath(DataPath) + "";

修改后的是:

DataPath = "App_Data/#data.mdb";

string constring = "provider=Microsoft.ACE.OLEDB.12.0;data source=" + HttpContext.Current.Server.MapPath(DataPath) + "";

注意:只需要修改为红色字体部份,其它的不用修改。也就是换一种连接数据库的驱动。

2、  在我们后台改为32位兼容模式:

登陆我们网站后台,进入管理中心 业务管理à虚拟主机管理à管理à程序兼容模式

提交后即可正常使用。

来源:西部数码


Public @ 2019-02-13 15:46:38

解决phpmyadmin上传文件大小限制的配置方法

1. 打开 php.ini 文件 首先,在你的服务器上找到 php.ini 文件。这个文件通常在 /etc/php/ 目录下,例如 /etc/php/7.4/apache2/php.ini 。 2. 修改文件上传限制 找到以下两个设置: upload_max_filesize = 2M post_max_size = 8M 这些设置控制可以上传和 POST 到服务器的最大文件大小。将它

Public @ 2023-04-03 15:50:14

IIS服务器手机访问不信任解决方法

如果在iis服务器上部署证书后,电脑IE,chrome浏览器正常访问,但手机或safari浏览器提示不可信,则需要做以下操作来解决此问题:一、首先,进入mmc的计算机用户里面:0.jpg1.jpg2.jpg3.jpg4.jpg二、进入到MMC计算机用户中后,在受信任的根证书颁发机构里面找到如图所示的证书,邮件剪切到“不信任的证书”(只有一个就剪切一个)5.jpg三、然后回到个人 里面,双击自己的域

Public @ 2012-10-14 15:47:16

在IIS7下使用ASP连接ACCESS数据库时提示如下错误的处理方法

“/”应用程序中的服务器错误。未在本地计算机上注册“microsoft.jet.oledb.4.0”提供程序。这是由于我们使用的Win2008系统是64位的,以前Win2003是32位。有以下两种解决方法:1、修改连接数据库的代码:如原代码是DataPath = "App_Data/#data.mdb";String constring = "provider=mic

Public @ 2019-02-13 15:46:38

access数据库常见问题处理

1. 打开 Access 数据库时遇到错误 产生这种错误通常是由于以下原因: - 数据库文件损坏或丢失 - 数据库所在的文件夹权限不足 - 数据库正在被其他用户或进程使用 解决方法: - 备份数据文件,如果需要的话可以使用恢复选项。 - 确保该文件所在文件夹具有足够权限。 - 确保没有其他用户或进程正在使用该文件。 2. 导入数据时遇到错误 产生这种错误通常是由于以下原因: - 字段

Public @ 2023-05-31 14:50:40

更多您感兴趣的搜索

0.564860s